DG15 by Pulse

Find frequently asked questions relating to DG versions of Pulse.

Back

Frequently Asked Questions (FAQ)

Which Windows operating system(s) is DG15 compatible with?

Exclusively Windows 7, 8, 8.1 and 10

Does DG15 work with a 32 bit computer?

No, DG15 will only work with a 64 bit computer.

Which security devices work with DG15?

Only KJ/DH devices will work with DG15. Other serial numbers will need to be replaced.

Does the update to DG15 include the device exchange, if required?

NO, the device exchange  cost needs to be added on top of the update cost if required.

Does an upgrade to a higher level include the device exchange, if required?

NO, the device exchange cost  needs to be added on top of the upgrade cost if required.

Which Corel versions will DG15 work with?

Every Corel 64 bit version will work (X5-X6-X7).

Which levels of DG15 include Corel integration?

Draw Fusion is available in Composer and upwards.

Can I use a Corel Home/Student Edition for the Corel integration?

No, in order to use Corel integration, you will need to have the Professional Edition.

Which DG15 levels can use templates and import names through XLS fles?

Composer and upwards.

What would a customer need in order to import XLS fles?

Offcial Microsoft Offce 2010 or newer (open source Offce will not work).